Routage catalyst

De Le wiki des TPs RSM
TP
Routage: mise en œuvre du réseaux

Ce TP permet de configurer un plan d'adressage et le routage statique puis de mettre en œuvre les protocoles de routage en migrant de RIP à OSPF.

Le but de ces Travaux Pratiques est d'étudier les techniques d'interconnexion de niveau 3. Dans un premier temps, nous allons mettre en œuvre un plan d'adressage très simple sur votre banc et tester les conditions pour avoir une interconnexion avec les autres bancs de la salle. Dans un second temps, nous allons mettre un oeuvre un protocole de routage simple (RIP), puis nous allons migrer cette configuration vers OSPF.


Cadre général

La salle TP possède un précâblage pour réseau local (cf. figure suivante). Un hub central permet de relier l'ensemble des bancs.

Attention.png L'utilisation d'un hub permet à chaque banc de voir le trafic produit par les autres bancs, si cette configuration n'est pas optimale, elle permet de mieux comprendre les échanges protocolaires. Il faudra par contre faire attention aux adresses source et destination des trames reçues

La configuration des salles est la suivante :

Plan.salle.B27.png   Plan.salle.B30.png
Attention.png Les connecteurs des câbles Ethernet peuvent être endommagés à cause des manipulations fréquentes dans la salle de TP. Lorsque vous câblez un équipement, vérifiez que les LED s'allument correctement des deux cotés.


Question.jpg
Notez le numéro de la salle (B27 ou B30), il sera nécessaire pour la définition du plan d'adressage.

Identification du matériel

L'ensemble du matériel utilisé pour les TPs réseaux est regroupé dans une baie au centre du banc.

Red arrow.png Identifier dans la baie:

  • 4 stations de travail (PC) Dell
  • 1 commutateur (switch) Cisco Catalyst 3560
  • 1 routeur Cisco 1841
  • 1 baie de brassage
  • 1 commutateur (switch) TP-Link
  • 1 commutateur clavier-vidéo-souris (KVM)
  • 1 faisceau de câbles réseaux verts

Baie facade.png

Le commutateur KVM permet de mutualiser l'écran, le clavier et la souris de la position située à droite du banc de travail entre les stations de travail 2,3,4. L’écran de gauche ainsi que le clavier et la souris sont totalement dédiés à la station de travail 1. Dans ce TP, les stations 3 et 4 sont inutilisées. Le commutateur KVM doit donc être en position 2 pour afficher la console du PC2 sur l'écran de droite.

Les équipements réseaux utilisés dans ce TP sont le routeur Cisco 1841 et le commutateur Cisco 3560. Le commutateur TP-Link n'est pas utilisé. Ces équipements seront configuré à travers leur console série, chacune connectée sur une station de travail différente :

  • Console série Commutateur Cisco sur le PC 1 (à gauche)
  • Console série Routeur Cisco sur le PC 2 (à droite)

Afin de faciliter les branchements, les interfaces réseaux à l’arrière des stations de travail sont déportées sur la baie de brassage. Pour connecter l'interface d'un des équipements réseaux (routeur ou switch) à l'une des interfaces des PCs, il suffit de connecter l'un des câbles réseaux verts d'un côté à la prise de l'équipement réseau et de l'autre à la prise de la baie de brassage correspondant à l'interface réseau du PC.

Attention.png Chaque câble réseau est identifié à travers une bague de couleur numérotée à chaque extrémité.

Pour les TPs réseaux, nous n'utiliserons que les deux premières interfaces des PCs 1 et 2. Ces interfaces sont reprises sur la baie de brassage de la façon suivante :

  • PC 1 Interface 0 => Baie de brassage Prise 1
  • PC 1 Interface 1 => Baie de brassage Prise 2
  • PC 2 Interface 0 => Baie de brassage Prise 7
  • PC 2 Interface 1 => Baie de brassage Prise 8

La prise 5 de la baie de brassage permet de connecter l'interface réseau d'un équipement ou d'un PC au réseau d'interconnexion de la salle.

Brassage TP réseau2.png

Plan d'adressage

La topologie utilisée pour ce TP est simple: PC1 et PC2 seront connecté au même sous-réseau, ainsi que l'interface interne du routeur. L'interface externe du routeur sera connectée au réseau d'interconnexion de la salle.

Pour le réseau d'interconnexion de la salle, le plan d'adressage sera le suivant :

  • le premier octet vaut 10
  • le deuxième octet représente le numéro de votre salle de TP (27 ou 30)
  • le troisième octet vaut 0
  • le dernier octet désigne numéro du banc.

Le plan d’adressage choisi du réseau interne au banc est le suivant:

  • le premier octet vaut 10
  • le deuxième octet représente le numéro de votre salle de TP (27 ou 30)
  • le troisième octet représente le numéro de votre banc de TP,
  • le dernier octet désigne un des équipements du poste de travail (1 pour le PC de gauche, 2 pour le PC de droite et 254 pour le routeur).

Le réseau représenté par l'interface eth1 du PC2 (de droite) est le suivant :

  • le premier octet vaut 10
  • le deuxième octet représente le numéro de votre salle de TP (27 ou 30)
  • le troisième octet représente le numéro de votre banc de TP + 100,
  • le dernier octet désigne un des équipements du poste de travail (2 pour le PC de droite).
Stylo.png
Donner l'adresse IP et sa longueur de préfixe pour les équipements suivants :




  • routeur Fe 0/0 :


  • routeur Fe 0/1 :


  • commutateur :


  • PC de gauche :


  • PC de droite :


Stylo.png
Quel est le préfixe et netmask associé au :
  • réseau d'interconnexion des bancs :


  • au réseau de votre banc :


Câblage

Le câblage à réaliser est donné sur la figure suivante :

Brassage TP IPv6.png

Red arrow.png Câbler le réseau suivant:

L'interface Fe0/0 du routeur doit être connectée au réseau d'interconnexion de la salle à travers la prise 5 de la baie de brassage.

Red arrow.png Connectez-le à l'interface Fe0/0 du routeur à la prise 5 de la baie de brassage.

L'interface Fe0/1 du routeur doit être connectée à l'interface 1 du commutateur.

Red arrow.png Connectez l'interface Fe0/1 du routeur à l'interface 1 du commutateur.

L'interface 2 du commutateur doit être connectée à l'interface eth0 du PC1.

Red arrow.png Connectez l'interface 2 du commutateur à l'interface eth0 du PC1 (Prise 1 de la baie de brassage).

L'interface 3 du commutateur doit être connectée à l'interface eth0 du PC2. l'autre interface eth1 n'est connectée à aucun réseau Ethernet mais servira pour injecter des préfixes dans les tables de routage.

Red arrow.png Connectez l'interface 3 du commutateur à l'interface eth0 du PC2 (Prise 7 de la baie de brassage).

L'interface 4 du commutateur sera utilisée pour capturer le trafic sur votre banc. L'analyseur de trafic se situera sur le PC1.

Red arrow.png Connectez l'interface 4 du commutateur à l'interface eth1 du PC1 (Prise 2 de la baie de brassage).

Mise en mode mirroring du commutateur

Red arrow.png Lancez le terminal série pour configurer le commutateur depuis la fenêtre Root Terminal sur le PC1

# minicom

Red arrow.png Réitérez cette manipulation pour le PC2.

Pour se connecter au switch:

Red arrow.png Sur le PC1, taper retour chariot, si vous voyez les lignes suivantes apparaître, repondez yes pour passer en mode configuration non assistée, sinon vous deviez voir directement l'invite Switch>

Would you like to terminate autoinstall? [yes]: yes


         --- System Configuration Dialog ---

Would you like to enter in the initial configuration dialog? [yes/no]: no 
Switch>

Le commutateur est prêt à être configuré.

Pour pouvoir visualiser le trafic sur le commutateur, nous devons placer le port 4 du commutateur en mode mirroring.

Red arrow.png Sur le PC1 taper les commandes suivantes :

Switch> enable
Switch# configure terminal
Switch(config)#
Switch(config)#monitor session 1 source vlan 1
Switch(config)#monitor session 1 destination interface Fa0/4
Switch(config)#exit
Switch#write
Building configuration...
[OK]

Première partie : Matrice de connectivité

Le première partie du TP va consister à remplir progressivement la matrice de connectivité. Cette partie (un peu fastidieuse) va nous permettre de lister une grande partie des causes d'erreur lors de la configuration de réseaux IP. En effet, le routage aller et retour étant dissocié, la configuration d'un équipement ne suffit pas, il faut que ceux sur la voie de retour le soit également.

Le tableau suivant donne les différents ping qui devront être réalisés à chaque étape. La première colonne donne l'adresse source et la machine sur laquelle elle devra être réalisée:

  • depuis PC2 (à droite) : il suffit de taper ping vers l'adresse de destination indiquée dans le tableau,
  • depuis le routeur cisco : ces routeurs ayant deux interfaces, il faudra préciser également l'adresse source en utilisant les commandes étendues. Interne désigne l'interface du réseau de votre banc et externe celle du réseau d'interconnexion.
Router#ping dst_addr source src_addr

Les lignes du tableau donnent les adresses de destination qui correspondent au plan d'adressage que vous avez précédemment défini.

Stylo.png
Indiquer sur le tableau les adresses IP de vos interfaces


Tableau de base


Depuis Votre banc Autre banc
PC2


routeur interne


routeur externe


routeur externe


routeur interne


PC2


PC2




















routeur interne




















routeur externe




















Analyseur réseau

Sur le PC1, nous allons utiliser l'interface eth1 pour écouter les trames qui circulent sur le réseau:

Red arrow.png Depuis la fenêtre d'administration du PC de gauche, activer l'interface connectée à l'interface de monitoring du switch

# ifconfig eth1 up

Red arrow.png Sur le PC1 (à gauche), lancer le programme d'analyse du trafic en sélectionnant dans le menu l'icône Wireshark

La fenêtre suivante apparaît :

Wireshark3.png

Red arrow.png Lancez la capture des trames en sélectionnant l'interface eth1 et cliquez ensuite sur Start

Configuration de l'interface de PC2

Red arrow.png Sur le PC2 (de droite) configurer l'adresse IPv4 sur l'interface eth0

# ifconfig eth0 10.TP._.2/24




Attention.png Vérifier bien que le masque de sous-réseau est correct. Si nécessaire, retaper la commande.
Question.jpg
Remplir le tableau suivant, en analysant les succès et les raisons des échecs
Interface PC2 configurée
Depuis Votre banc Autre banc
PC2


routeur interne


routeur externe


routeur externe


routeur interne


PC2


PC2




















routeur interne


X X X X X X
routeur externe


X X X X X X

Configuration de l'interface interne du cisco

Red arrow.png Sur le routeur cisco configurer l'adresse IPv4 sur l'interface fe0/1

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 10.TP._.254 255.255.255.0
Router(config-if)#end
Router#write

Red arrow.png Depuis le PC2 tentez de pinger l'interface

# ping 10.TP._.254
PING 10.27.2.254 (10.27.2.254) 56(84) bytes of data.

--- 10.27.2.254 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2002ms

L'interface du routeur Cisco administrativement désactivée.

Red arrow.png Pour la rendre active, sur le routeur Cisco, tapez la commande :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/1
Router(config-if)#no shutdown
Router(config-if)#end
Router#write
Building configuration...

*Aug 18 08:46:51.844: %SYS-5-CONFIG_I: Configured from console by console
*Aug 18 08:46:52.396: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state p
*Aug 18 08:46:53.632: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEther]
Router#
*Aug 18 08:46:59.936: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEther


Question.jpg
Remplir le tableau suivant, en analysant les succès et les raisons des échecs
Interface interne du routeur configurée
Depuis Votre banc Autre banc
PC2


routeur interne


routeur externe


routeur externe


routeur interne


PC2


PC2




















routeur interne




















routeur externe


X X X X X X

Configuration de l'interface externe du cisco

Red arrow.png Sur le routeur cisco configurer l'adresse IPv4 sur l'interface fe0/0

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.TP.0._ 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write
*Aug 18 08:52:59.820: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK]


Red arrow.png Visualiser la table de routage du routeur

Router#show ip route




Stylo.png
Comment ont été apprises ces routes ?


Question.jpg
Remplir le tableau suivant, en analysant les succès et les raisons des échecs
Interface externe du routeur configurée
Depuis Votre banc Autre banc
PC2


routeur interne


routeur externe


routeur externe


routeur interne


PC2


PC2




















routeur interne




















routeur externe




















Configuration de la route vers l'autre banc de test

Red arrow.png Sur le routeur cisco configurer la table de routage pour ajouter le préfixe correspondant au banc avec lequel vous faites des tests. La syntaxe est la suivante :
ip route <prefixe> <netmask> <routeur>

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip route 10.TP._.0 255.255.255.0 10.TP.0._
Router(config)#end
Router#write
*Aug 18 09:02:07.528: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK]

Red arrow.png Visualiser la table de routage du routeur

Router#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.TP.0.0 is directly connected, FastEthernet0/0
S       10.27.3.0 [1/0] via 10.27.0.3
C       10.TP._.0 is directly connected, FastEthernet0/1
Router#


Red arrow.png Attendre que l'autre banc ait aussi effectué la configuration

Question.jpg
Remplir le tableau suivant, en analysant les succès et les raisons des échecs
Route vers l'autre banc
Depuis Votre banc Autre banc
PC2


routeur interne


routeur externe


routeur externe


routeur interne


PC2


PC2




















routeur interne




















routeur externe




















Configuration d'une route par défaut

Red arrow.png Sur un seul des deux bancs, configurer sur PC2 une route par défaut vers votre routeur.

Stylo.png
Quelle adresse du routeur doit être utilisée dans la commande


# ip route add default via 10.TP._.254

Red arrow.png Visualiser la table de routage du PC2

# netstat -rn




Question.jpg
Depuis ce PC2 remplir le tableau suivant, en analysant les succès et les raisons des échecs
Route vers l'autre banc
Depuis Votre banc Autre banc
PC2


routeur interne


routeur externe


routeur externe


routeur interne


PC2


PC2




















routeur interne




















routeur externe




















Red arrow.png Configurer une route par defaut sur le deuxième banc PC2 et vérifier la connectivité entre les deux PC

Protocole de routage

Si l'on voulait avoir une connectivité avec tous les bancs de TP, il faudrait configurer manuellement tous les préfixes. Le but de ce partie est d'automatiser le remplissage de la table de routage en utilisant un protocole de routage:

  • dans un premier temps nous allons utiliser RIP sur les routeurs cisco,
  • puis nous lancerons OSPF sur PC2 qui émulera un routeur vers le site de l'entreprise,
  • nous migrerons le coeur du réseau de RIP vers OSPF
  • nous diviserons en aire le réseau OSPF.

Configuration de RIP sur le routeur Cisco

Red arrow.png Vérifiez que l'analyseur est en mode capture

Red arrow.png Tout d'abord, désactivez sur le routeur Cisco la route statique vers l'autre banc:

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip route 10.TP._.0 255.255.255.0 10.TP.0._ (_: numéro de l'autre banc)

Red arrow.png Sur le routeur Cisco, tapez:

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 10.0.0.0
Router(config-router)#end
Router#write
Router#debug ip rip events

La commande debug ip rip events permet d'afficher sur le cisco les événements concernant RIP (émission et réception de messages RIP).

Red arrow.png Analysez la trame émise par le routeur sur le réseau local

Stylo.png
Pourquoi ne voit-on pas l'annonce pour le réseau local dans le message RIP ?


Question.jpg
Quels sont les réseaux visibles depuis le réseau local ?



Stylo.png
Pourquoi le champ Next Hop est à zéro ?


Red arrow.png Sur le cisco, désactivez les traces des messages RIP en tapant :

Router#no debug ip rip events

Red arrow.png visualisez la table de routage en tapant:

Router#sh ip ro




Red arrow.png Sur le Cisco, visualisez la base de données RIP en tapant

Router#sh ip rip database




Stylo.png
Quelles sont les différences entre la table de routage (sh ip ro) et la base de données (sh ip rip database) ?


OSPF sur le banc

Lancement de zebra

Pour lancer OSPF sur le PC2, nous allons utiliser le logiciel quagga qui est très proche dans sa philosophie des commandes IOS de Cisco avec quelques legères différences. Contrairement à l'IOS qui intègre monolytiquement toutes les fonctionnalités, quagga est composé de plusieurs programmes (daemons) qui doivent être lancée en tâche de fond pour pouvoir fonctionner:

  • zebra est le programme de gestion des interfaces. Nous allons l'utiliser pour associer plusieurs préfixes sur l'interface eth1. ces préfixes représenteront le réseau de production de l'entreprise que nous voulons simuler.
  • un programme par protocole de routage : ripd, ripngd, ospfd, ospf6d, bgpd. Dans notre cas, nous nous interesserons à ospfd.

La communication entre ces programmes et l'administrateur système peut se faire par telnet en local (127.0.0.1) en précisant un numéro de port défini pour chacun de ces programme.

Red arrow.png Générez les fichiers de configuration zebra pour le banc de tp en tapant sur le PC2 et en remplaçant TP par le numéro de la salle (27 ou 30) et banc par le numéro de votre banc (1 à 8) :

# cd /home/user/TPs/TP_Routage
# ./TPgen TP banc
Salle TP generation de la configuration pour le banc _
# cat /home/user/TPs/TP_Routage/zebra.conf




Nous allons configurer l'interface eth1, bien qu'aucun réseau ni soit connecté. Le but est de pouvoir annoncer des routes dans OSPF.

Red arrow.png Sur le PC2, taper :

# ifconfig eth1 10.TP.10_.2/24
# ifconfig eth1



Red arrow.png Lancez sur PC2, le programme zebra pour la gestion des interfaces

 # cp zebra.conf /etc/quagga/
 # service zebra start


Red arrow.png Se connecter au processus zebra par telnet

#telnet 127.0.0.1 zebra
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

Hello, this is Quagga (version 1.2.4).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password:zebra (n'apparaît pas à l'écran)
Router> ena
Password:zebra (n'apparaît pas à l'écran)
Router# sh interface eth1




lancement d'ospf sur PC2

Red arrow.png Assurez vous que l'analyseur du PC1 est en mode capture

Red arrow.png Sur le PC2, ouvrir un nouvel onglet dans la fenêtre shell (shift-control T) et lancer le daemon OSPF

# cat ospfd.conf




# cp ospfd.conf /etc/quagga/
# service ospfd start

Red arrow.png Sur le PC2, connectez vous au daemon

# telnet 127.0.0.1 ospfd
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

Hello, this is Quagga (version 1.2.4).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password:zebra (n'apparaît pas à l'écran)
ospfd> ena
ospfd#sh running-config




Red arrow.png Dans la fenêtre quagga OSPF du PC2, tapez :

ospfd# sh ip ospf neighbor
 OSPF Routing Process not enabled
ospfd#
Question.jpg
Voyez vous du trafic OSPF sur le réseau du banc ?


Nous devons indiquer au processus les interfaces qui vont participer à OSPF ainsi que l'aire dans laquelle elles se trouvent. Dans notre cas, il s'agit de l'interface eth0 qui est dans l'aire 0 (backbone).

Red arrow.png Dans la fenêtre quagga OSPF du PC2, tapez :

ospfd# conf t
ospfd(config)# router ospf
ospfd(config-router)# network 10.TP._.0/24 area 0.0.0.0
ospfd(config-router)# end
Stylo.png
Quel trafic OSPF voit-on sur le réseau local ?


Question.jpg
Qui est le routeur désigné ?


Red arrow.png Dans la fenêtre quagga OSPF du PC2, tapez :

ospfd# sh ip ospf neighbor




Question.jpg
Est-ce qu'il y a des voisins à PC2 ?


lancement d'ospf sur le cisco

Red arrow.png Sur le routeur cisco, tapez :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 10.TP._.0 0.0.0.255 area 0
Router(config-router)#end
*Aug 19 15:07:49.484: %OSPF-5-ADJCHG: Process 1, Nbr 10.27.124.1 on FastEthernet
*Aug 19 15:07:53.408: %SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration...
[OK]
Attention.png Les syntaxes entre les routeurs Cisco et Quagga sont quelques peu différentes. Cisco impose un numéro de processus à OSPF car plusieurs instances indéprendantes peuvent tourner sur le même routeur. Cisco utilise également une syntaxe particulière pour désigner les réseaux dans la commande network. Il s'agit d'un netmask inversé. Les bits à 0 indiquent la partie fixe du préfixe et les bits à 1, la partie variable.
Question.jpg
Quel trafic OSPF s'est produit sur le réseau du banc ?


Stylo.png
Est-ce que l'identifiant du routeur, correspond à son adresse IP sur le lien ?


Question.jpg
Sur le cisco, tapez :
Router#sh ip ospf database




Question.jpg
Quels sont les routeurs connus dans la base de données ?



Stylo.png
Le processus OSPF sur PC2 a-t-il les mêmes informations dans sa base de données ?


Red arrow.png vérifiez en tapant dans la fenêtre OSPF de Quagga:

ospfd# sh ip ospf database




Examinez plus en détail les informations concernant les réseaux annoncés par OSPF.

Red arrow.png Demandez l'information d'état de lien pour le routeur du PC2

Red arrow.png Sur le cisco, tapez :

Router#sh ip ospf database router 10.TP._.2




Red arrow.png Sur le PC2, dans la fenêtre ospfd tapez :

ospfd# show ip ospf interface eth1




Question.jpg
Voit-on les réseaux qui sont configurés sur l'interface eth1 du PC2 ?


Il faut indiquer que l'interface eth1 du PC2 se trouve également dans l'aire 0.0.0.0

Red arrow.png Sur le PC2, dans la fenêtre ospfd tapez :

ospfd# conf t
ospfd(config)# router ospf
ospfd(config-router)# network 10.TP.10_.0/24 area 0.0.0.0
ospfd(config-router)# end
ospfd# show ip ospf interface eth1




Red arrow.png Sur le cisco, tapez :

Router#sh ip ospf database router 10.TP.10_.2




Le routeur PC2 annonce les deux réseaux.

Red arrow.png Sur le cisco, tapez :

Router#sh ip ro




Question.jpg
Voit-on sur le PC2 les routes apprises par le cisco avec RIP ?


Redistribution des routes RIP sur le banc

Il faut explicitement indiquer au processus OSPF de distribuer les routes apprises par d'autres protocoles de routage.

Red arrow.png Sur le routeur Cisco, taper :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#redistribute rip subnets metric 20
Router(config-router)#end
Question.jpg
Les autres bancs apprennent-ils les routes associées à l'interface eth1 du PC2 ?



Dans les tables de routage la notation [x/y] indique la précédence (x) et le coût du préfixe. La précédence permet de choisir quel protocole de routage va mettre l'information dans la table au cas où le même préfixe est annoncé de plusieurs manières. Le coût correspond à la métrique du protocole de routage.

Stylo.png
Peut-on comparer les métriques d'OSPF et de RIP ?


Question.jpg
Remplissez le tableau suivant en indiquant comment l'information est apprise (par quel protocole de routage) en indiquant précédence et coût (pour connaitre ces informations il faut taper la commande sh ip route sur le cisco et dans la fenêtre zebra du PC2).


interconnexion RIP et banc OSPF
Depuis Préfixe du banc Prefixe PC2 eth1 Préfixe d'interconnexion Préfixe d'un autre banc
PC2











Cisco











Généralisation d'OSPF

Nous allons mettre OSPF sur le réseau d'interconnexion en placant l'interface FastEthernet 0/0 dans l'aire 0.0.0.0.

Red arrow.png Sur le Cisco, tapez :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 10.TP.0.0 0.0.255.255 area 0.0.0.0
Router(config-router)#end
Router#
Question.jpg
Comme précédemment, remplissez le tableau suivant. Quelles sont les différences ?


OSPF généralisé + RIP
Depuis Préfixe du banc Prefixe PC2 eth1 Préfixe d'interconnexion Préfixe d'un autre banc
PC2











Cisco











Division en aire

Pour finir, nous allons découper en aire le réseau. Chaque banc sera vu comme une aire OSPF qui portera le numéro du banc, et le reseau d'interconnexion restera dans l'aire 0.

Red arrow.png Sur le routeur Cisco, tapez :

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)# network 10.TP._.0 0.0.0.255 area 0.0.0._
Router(config-router)#end
Router(config-router)#

Red arrow.png Verifiez les voisinages en tapant, sur le routeur Cisco :

Router#sh ip ospf neighbor




Question.jpg
Pourquoi ne voit-on plus le routeur du PC2 ?


Red arrow.png Sur le PC2, dans la fenêtre ospfd, taper :

ospfd#conf t
ospfd(config)#router ospf
ospfd(config-router)#no network 10.TP._.0/24 area 0.0.0.0
ospfd(config-router)#no network 10.TP.10_.0/24 area 0.0.0.0
ospfd(config-router)#network 10.TP.0.0/16 area 0.0.0._
ospfd(config-router)#end
ospfd#

Red arrow.png Sur le routeur Cisco, tapez :

Router# sh ip ro



Question.jpg
Quels sont les nouveaux types d'annonce d'état de lien (LSA) que l'on retrouve dans la base de données du PC2 et du Cisco?




Question.jpg
Les bases de données sont-elles identiques ?


Remise à zéro des bancs

Red arrow.png Déconnectez tous les câbles réseaux entre les équipements et la baie de brassage.

Red arrow.png Sur le routeur et le commutateur, effacez les configurations avec la commande suivante :

Switch#write erase
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] <return>
[OK]
Erase of nvram: complete
Switch#
3d23h: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Switch#reload

System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]<return>
...
Would you like to terminate autoinstall? [yes]: yes


        --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no
Switch>

Red arrow.png Eteignez les PCs avec la commande :

# shutdown

Broadcast message from root@pc-b27-21 (pts/3) (Mon Aug 11 17:44:28 2008): 

The system is going down for reboot NOW!
Outils personnels