DNS

De Le wiki des TPs RSM
TP
DNS : Déploiement



Cadre général

La salle TP possède un précâblage pour réseau local (cf. figure suivante). Un hub central permet de relier l'ensemble des bancs.

Attention.png L'utilisation d'un hub permet à chaque banc de voir le trafic produit par les autres bancs, si cette configuration n'est pas optimale, elle permet de mieux comprendre les échanges protocolaires. Il faudra par contre faire attention aux adresses source et destination des trames reçues

La configuration des salles est la suivante :

Plan.salle.B27.png   Plan.salle.B30.png
Attention.png Les connecteurs des câbles Ethernet peuvent être endommagés à cause des manipulations fréquentes dans la salle de TP. Lorsque vous câblez un équipement, vérifiez que les LED s'allument correctement des deux cotés.


Question.jpg
Notez le numéro de la salle (B27 ou B30), il sera nécessaire pour la définition du plan d'adressage.

Identification du matériel

L'ensemble du matériel utilisé pour les TPs réseaux est regroupé dans une baie au centre du banc.

Red arrow.png Identifier dans la baie:

  • 4 stations de travail (PC) Dell
  • 1 commutateur (switch) Cisco Catalyst 3560
  • 1 routeur Cisco 1841
  • 1 baie de brassage
  • 1 commutateur (switch) TP-Link
  • 1 commutateur clavier-vidéo-souris (KVM)
  • 1 faisceau de câbles réseaux verts

Baie facade.png

Le commutateur KVM permet de mutualiser l'écran, le clavier et la souris de la position située à droite du banc de travail entre les stations de travail 2,3,4. L’écran de gauche ainsi que le clavier et la souris sont totalement dédiés à la station de travail 1. Dans ce TP, les stations 3 et 4 sont inutilisées. Le commutateur KVM doit donc être en position 2 pour afficher la console du PC2 sur l'écran de droite.

Les équipements réseaux utilisés dans ce TP sont le routeur Cisco 1841 et le commutateur Cisco 3560. Le commutateur TP-Link n'est pas utilisé. Ces équipements seront configuré à travers leur console série, chacune connectée sur une station de travail différente :

  • Console série Commutateur Cisco sur le PC 1 (à gauche)
  • Console série Routeur Cisco sur le PC 2 (à droite)

Afin de faciliter les branchements, les interfaces réseaux à l’arrière des stations de travail sont déportées sur la baie de brassage. Pour connecter l'interface d'un des équipements réseaux (routeur ou switch) à l'une des interfaces des PCs, il suffit de connecter l'un des câbles réseaux verts d'un côté à la prise de l'équipement réseau et de l'autre à la prise de la baie de brassage correspondant à l'interface réseau du PC.

Attention.png Chaque câble réseau est identifié à travers une bague de couleur numérotée à chaque extrémité.

Pour les TPs réseaux, nous n'utiliserons que les deux premières interfaces des PCs 1 et 2. Ces interfaces sont reprises sur la baie de brassage de la façon suivante :

  • PC 1 Interface 0 => Baie de brassage Prise 1
  • PC 1 Interface 1 => Baie de brassage Prise 2
  • PC 2 Interface 0 => Baie de brassage Prise 7
  • PC 2 Interface 1 => Baie de brassage Prise 8

La prise 5 de la baie de brassage permet de connecter l'interface réseau d'un équipement ou d'un PC au réseau d'interconnexion de la salle.

Brassage TP réseau2.png

Architecture du TP

Au cours de ce TP, nous allons mettre en place un serveur DNS dans un réseau IPv6 sur votre banc. Voici l'architecture réseau que vous allez mettre en place.

Architecture Niveau 3

DNS Archi L3 b.png

L'architecture niveau 3 nous montre les 2 réseaux IPv6 du banc. Sur le premier réseau, nous allons connecter le PC serveur, qui sera le PC à gauche de votre banc. Le PC à droite de votre banc sera le PC client, qui sera connecté au second réseau de votre banc.

Red arrow.png Repérez le PC serveur, situé à gauche de votre banc, et le PC client, situé à droite de votre banc.

Ces deux réseaux IPv6 seront gérés par un routeur Cisco 1800. Ce routeur sera connecté au réseau d'interconnexion de la salle pour fournir la connectivité IPv6 à votre banc.

Red arrow.png Repérez le routeur Cisco 1800.

Architecture Niveau 2

DNS Archi L2 b.png

Le routeur Cisco ne possède que 2 interfaces réseau. La première sera utilisée pour le réseau d'interconnexion. L'architecture réseau du TP nécessite donc la mise en place de VLANs. La seconde interface du routeur servira à diffuser le VLAN correspondant au réseau IPv6 de votre banc vers un commutateur Cisco 3560. Vous configurerez ce commutateur pour attribuer ce VLAN aux interfaces sur lesquelles seront connectés les 2 PCs.

Red arrow.png Repérez le switch Cisco 3650.

Architecture Niveau 1

Voici le schéma de câblage pour ce TP :

Brassage TP IPv6.png

L'interface Fe0/0 du routeur doit être connectée au réseau d'interconnexion de la salle à travers la prise 5 de la baie de brassage.

Red arrow.png Connectez-le à l'interface Fe0/0 du routeur à la prise 5 de la baie de brassage.

L'interface Fe0/1 du routeur doit être connectée à l'interface 1 du commutateur.

Red arrow.png Connectez l'interface Fe0/1 du routeur à l'interface 1 du commutateur.

L'interface 2 du commutateur doit être connectée à l'interface 0 du PC serveur (PC1).

Red arrow.png Connectez l'interface 2 du commutateur à l'interface eth0 du PC1 (Prise 1 de la baie de brassage).

L'interface 3 du commutateur doit être connectée à l'interface eth0 du PC client (PC2).

Red arrow.png Connectez l'interface 3 du commutateur à l'interface eth0 du PC2 (Prise 7 de la baie de brassage).

L'interface 4 du commutateur sera utilisée pour capturer le trafic sur votre banc. L'analyseur de trafic se situera sur le PC serveur.

Red arrow.png Connectez l'interface 4 du commutateur à l'interface eth1 du PC1 (Prise 2 de la baie de brassage).

Démarrage des PCs

Les deux PC doivent être sous tension. Une bannière de login doit être présente. Si ce n’est pas le cas, appelez votre encadrant.

Sur le commutateur et les PC:

Red arrow.png Vérifiez l’état des LED pour voir quels équipements sont "actifs" sur le réseau.

Sur chacun des PC :

Red arrow.png Dans la fenêtre de login PC, taper comme utilisateur : user

Red arrow.png Dans la fenêtre suivante taper le mot de passe : pass4user

Les outils utiles pour le TP sont présents dans le menu Activités en haut à gauche de l'écran.

MenuTP2.png

Red arrow.png Lancer un terminal avec les droit administrateur en sélectionnant l'outil Root Terminal

Red arrow.png Le système demande le mot de passe: taper pass4user

Red arrow.png Réitérez cette manipulation pour le second PC.

Etape 1 : Configuration niveau 2 du banc de TP sur le commutateur

Vous allez tout d'abord configurer l'architecture Niveau 2 sur le commutateur de votre banc.

Red arrow.png Lancez le terminal série pour configurer le commutateur depuis la fenêtre Root Terminal sur le PC1

# minicom

La console série ouverte sur le commutateur apparait.

Red arrow.png Tapez retour chariot, si vous voyez les lignes suivantes apparaître, repondez yes pour passer en mode configuration non assistée, sinon vous deviez voir directement l'invite Switch>

Would you like to terminate autoinstall? [yes]: yes


         --- System Configuration Dialog ---

Would you like to enter in the initial configuration dialog? [yes/no]: no
Switch>

Le commutateur est prêt à être configuré.

Comme pour une station de travail, un commutateur a deux mode de fonctionnement. Vous êtes pour l’instant connecté dans le mode utilisateur. Pour pouvoir configurer l’équipement, vous devez passer dans le mode super-utilisateur.

Red arrow.png Tapez la commande IOS (système d’exploitation des routeurs/commutateurs Cisco) :

Switch>enable

L’invite change pour :

Switch#

Le format de l’invite est important car il indiquera dans quel menu de configuration vous vous trouvez.

Attention.png SI VOUS RESTEZ TROP LONGTEMPS INACTIF SUR LE COMMUTATEUR. CELUI-CI REPASSERA EN MODE UTILISATEUR. POUR REVENIR EN MODE PRIVILÉGIÉ, IL FAUDRA RETAPER enable.

Pour connaître les interfaces disponibles sur le switch, tapez :

Switch#show interfaces status



Configuration du VLAN

Dans l'architecture de niveau 2, nous avons défini le VLAN numéroté de la façon suivante :

  • 10_ : VLAN du réseau où _ correspond à votre numéro de banc

Les interfaces Fa0/1, Fa0/2 et Fa0/3 sont connectées au routeur, au PC serveur et au PC client, respectivement. Vous devez donc leur attribuer le VLAN 10_.

Pour commencer la configuration des interfaces, vous devez passez en mode configuration

Switch# configure terminal


Red arrow.png Configurez sur le commutateur les interfaces FastEthernet0/2 sur le vlan 10_

Switch(config)# interface FastEthernet0/1
Switch(config-if)# switchport access vlan 10_
Switch(config-if)# switchport mode access
Switch(config-if)# exit
Switch(config)# interface FastEthernet0/2
Switch(config-if)# switchport access vlan 10_
Switch(config-if)# switchport mode access
Switch(config-if)# exit
Switch(config)# interface FastEthernet0/3
Switch(config-if)# switchport access vlan 10_
Switch(config-if)# switchport mode access
Switch(config-if)# exit
Switch(config)# exit
Switch#

Red arrow.png Vérifiez la configuration des interfaces:

Switch#show interfaces status



Configuration du port moniteur

Nous allons passer en mode configuration pour placer le port 4 du commutateur en mode monitoring pour qu'il reçoive l'ensemble des trames émises par chacun des deux PC (vlan 10_). Ce port sera connecté à l'interface eth1 du PC serveur, ce qui permettra d'observer les trames avec un analyseur.

Red arrow.png Tapez :

Switch# configure terminal
Switch(config)#monitor session 1 source vlan 10_
Switch(config)#monitor session 1 destination interface Fa0/4
Switch(config)#exit
Switch#


Red arrow.png vérifiez que la commande a bien été exécutée en tapant :

Switch# sh interfaces status



Mise en marche de l’analyseur réseau sur le PC serveur

Sur le PC serveur, nous allons utiliser le port eth1 pour écouter les trames qui circulent sur le réseau:

Afin que l'interface eth1 du PC serveur ne soit pas impactée par les messages de configuration IPv6 reçus, il faut désactiver l'autoconfiguration sur cette interface.

Red arrow.png Sur le PC serveur, activez l'interface eth1 et désactiver l'autoconfiguration :

# ifconfig eth1 up
# echo 0 > /proc/sys/net/ipv6/conf/eth1/accept_ra

Red arrow.png Lancez le programme d'analyse du trafic avec un accès root en sélectionnant dans le menu TP / Wireshark

La fenêtre suivante apparaît :

Wireshark3.png


Red arrow.png Lancez la capture des trames en sélectionnant l'interface eth1 et cliquez ensuite sur Start

Afin de ne voir que les messages IPv6 qui nous intéressent ici, vous pouvez utiliser le filtre de visualisation

Red arrow.png Dans le champ Filter en haut de la fenêtre de capture, entrez la valeur ipv6


Etape 2 : Etablissement du plan d'adressage

Le plan d'adressage utilisé pour ce TP suit la règle d'adressage hiérarchique mise en oeuvre depuis la politique d'allocation CIDR décidée au début des années 1990. Cette politique s'applique aussi bien en IPv4 qu'en IPv6 :

  • L'IANA, organisation mondiale de gestion des adresses, délègue des blocs d'adresses aux Registres Internet Régionaux (RIR).
  • Chaque RIR alloue des blocs d'adresses aux Registres Internet Locaux (LIR, typiquement des opérateurs/FAI) de sa région (en Europe, c'est le RIPE-NCC).
  • Chaque LIR attribue ensuite des blocs d'adresses à ses clients finaux (entreprises, particuliers...).
  • Chaque client gère enfin ces adresses pour les affecter à ses équipements/services réseaux.

Dans le cas d'IMT Atlantique, le LIR est RENATER. Le préfixe IPv6 utilisé par RENATER est :

2001:660::/32

RENATER a attribué à IMT Atlantique site de Rennes le préfixe suivant

2001:660:7301::/48

Les administrateurs réseau du site de Rennes ont décidé d'adresser hiérarchiquement les salles de TP. Pour chaque salle de TP le préfixe :

2001:660:7301:TP00::/64

est attribué au réseau d'interconnexion. Les préfixes à utiliser pour le réseau de votre banc est défini de la manière suivante :

2001:660:7301:TP_0::/64 Réseau serveur (vlan 10_)

_ représente votre numéro de banc


Question.jpg
Quel sera le préfixe IPv6 à utiliser sur votre banc ?




Etape 3 : Connexion du routeur au réseau de la salle

La configuration Niveau 2 de votre banc étant terminée, vous n'avez plus de configuration à effectuer sur le commutateur. Vous allez maintenant configurer le routeur.

Red arrow.png Lancez le terminal série pour configurer le routeur depuis la fenêtre Root Terminal sur le PC2

# minicom

Red arrow.png Allumez le routeur.

Le routeur va normalement démarrer en mode configuration. Répondez à quelques questions (nom du routeur, mot de passe administrateur) et vous devriez arriver à l'invite de commande pour la configuration.

Red arrow.png Passez en mode administrateur

Router> enable

Red arrow.png Vérifiez la configuration IPv6 des interface au démarrage du routeur

Router# show ipv6 interface brief 

Vous allez maintenant configurer l'interface FastEthernet0/0 du routeur, connectée au réseau d'interconnexion de la salle. Dans le plan d'adressage de l'école, ce réseau a pour préfixe :

2001:660:7301:TP00::/64

Vous allez donc configurer cette interface avec une adresse de ce lien. Pour construire cette adresse, il vous manque les 64 derniers bits. Ces bits seront fixés en fonction de votre banc :

0000:0000:0000:000_    _=numéro de banc
Question.jpg
Quelle sera l'adresse IPv6 de votre routeur ?




Red arrow.png Configurez sur le routeur l'interface FastEthernet0/0

Router# configure terminal
Router(config)# interface FastEthernet0/0
Router(config-if)# no shutdown
Router(config-if)# ipv6 address 2001:660:7301:TP00::_/64
Router(config-if)# ipv6 enable
Router(config-if)# exit
Router(config)#

Red arrow.png Activez la fonction de routage du routeur

Router(config)# ipv6 unicast-routing
Router(config)# exit
Router#

Red arrow.png Vérifiez la configuration de l'interface

Router# show ipv6 interface brief


Afin que le réseau soit informé des préfixes que vous allez déployer sur votre banc, votre routeur doit activer un processus de routage. Pour ce TP, nous utiliserons le protocole RIP.

Red arrow.png Activez le protocole RIP sur l'interface vers le réseau d'interconnexion

Router# configure terminal
Router(config)# ipv6 router rip cisco
Router(config-router)# redistribute connected
Router(config-router)# exit
Router(config)# interface FastEthernet0/0
Router(config-if)# ipv6 rip cisco enable
Router(config-if)# exit
Router(config)# exit
Router#

Le protocole de routage RIP permet au routeur de votre banc de s'annoncer comme routeur pour tous les réseaux qu'il gère (redistribute connected). RIP permet aussi de récupérer des routes annoncées par d'autres routeurs.


Étape 4 : Mise en place du réseau du banc

Maintenant que votre routeur est connecté au réseau de la salle, vous allez configurer le réseau de votre banc Ce réseau va utiliser les fonctionnalités de configuration automatique des adresses.

Configuration du réseau côté routeur

Vous allez maintenant configurer l'interface du routeur vers le réseau du banc. Cette interface est connectée sur le VLAN de votre banc, le VLAN 10_.

Red arrow.png Activez l'interface physique et l'interface virtuelle du routeur vers le VLAN 10_ où _ est votre numéro de banc.

Routeur# configure terminal
Routeur(config)# interface FastEthernet0/1
Routeur(config-if)# no shutdown
Routeur(config-if)# ipv6 enable
Routeur(config-if)# exit
 Routeur(config)# exit
Routeur#


Vous allez maintenant configurer l'adresse IPv6 globale de l'interface FastEthernet0/1. Dans le plan d'adressage du TP, le préfixe IPv6 est le suivant :

2001:660:7301:TP_1::/64 _=numéro de banc

Les 64 derniers bits de l'adresse (identifiant d'interface) vont être déterminés à partir de l'identifiant matériel.

Red arrow.png Configurez l'interface du vlan 10_ sur le routeur

Routeur# configure terminal
Routeur(config)# interface FastEthernet0/1
Routeur(config-if)# ipv6 address 2001:660:7301:TP_1::/64 eui-64
Routeur(config-if)# exit
Routeur(config)# exit
Routeur#

Red arrow.png Vérifiez la configuration des adresses IPv6 sur le routeur

Routeur# show ipv6 interface brief


Vous allez maintenant configurer le mécanisme permettant la configuration automatique des "hosts" sur le réseau du banc. Ce mécanisme permet au routeur d'annoncer sur le lien le préfixe IPv6 à utiliser pour fabriquer l'adresse, ainsi que d'autres paramètres comme le MTU. Ce mécanisme s'appelle Annonce de routeur (Routeur Advertisement ou RA).

Red arrow.png Configurer le mécanisme d'annonces de routeur sur le réseau serveur

Routeur# configure terminal
Routeur(config)# interface FastEthernet0/1
Routeur(config-if)# ipv6 nd prefix 2001:660:7301:TP_1::/64 2592000 604800
Routeur(config-if)# ipv6 nd ra interval 30
Routeur(config-if)# exit
Routeur(config)# exit
Routeur#

Configuration des PC

Le réseau du banc est maintenant configuré, il vous reste à configurer les PCs.

Sur le PC client :

Red arrow.png Vérifiez la configuration IPv6 initiale

Standard Linux
# ifconfig
# ip -6 addr

Pour que le PC client se configure sur le réseau, il vous faut activer l'interface eth0 qui l'y connecte

Red arrow.png Activez l'interface eth0 de la machine client

# ifconfig eth0 up

Red arrow.png Vérifiez la configuration IPv6

Standard Linux
# ifconfig
# ip -6 addr


Red arrow.png Vérifiez l'état de la table de routage

Standard Linux
# netstat -rn6
# ip -6 route

On fait la même chose pour le PC serveur :

Red arrow.png Vérifiez la configuration IPv6 initiale

Standard Linux
# ifconfig
# ip -6 addr

Pour que le PC serveur configure sur le réseau, il vous faut activer l'interface eth0 qui l'y connecte

Red arrow.png Activez l'interface eth0 de le PC serveur

# ifconfig eth0 up

Red arrow.png Vérifiez la configuration IPv6

Standard Linux
# ifconfig
# ip -6 addr


Red arrow.png Vérifiez l'état de la table de routage

Standard Linux
# netstat -rn6
# ip -6 route

Red arrow.png Testez la connectivité acquise par l'auto-configuration

# ping6 2001:660:7301:TP00::_ _=numéro de votre banc
# ping6 2001:660:7301:TP00::_ _=numéro d'un autre banc
# ping6 2001:660:7301:1::1
# ping6 www.afnic.fr


Question.jpg
Que manque-t-il pour que le dernier test de connectivité puisse réussir ?




La configuration du DNS n'est pas transmise par le message d'annonce de routeur.

Configuration du DNS

Red arrow.png Ouvrez l'éditeur gedit dont l'icône se trouve sur le bureau

Red arrow.png Ouvrez le fichier /etc/resolv.conf et renseignez la valeur suivante, puis enregistrez

nameserver 2001:660:7301:1::1

Red arrow.png Vérifiez que le dernier test de connectivité fonctionne

La configuration automatique depuis le routeur permet de renseigner les paramètres nécessaires à la configuration de l'adresse d'une interface et de la table de routage. Par contre, ce mécanisme ne gère pas la configuration de paramètres des couches supérieures, comme par exemple la découverte automatique de l'adresse du serveur récursif DNS ("cache resolver").

Étape 5 : Configuration d'un serveur de nommage

Vous allez maintenant configurer un serveur de nommage sur le PC serveur. Ce serveur va permettre de gérer la correspondance entre les adresses IPv6 déployées sur votre réseau et des noms, plus facile à manipuler. Les 2 PCs seront ensuite configurés pour utiliser ce serveur comme résolveur.

Pour pouvoir entrer plus facilement l'adresse du serveur DNS dans la configuration, vous allez donner à l'interface eth0 du serveur une adresse IPv6 statique plus facile à retenir. Elle utilisera le même préfixe IPv6 du lien, mais l'identifiant d'interface sera fixé sur une valeur choisie. Par exemple, vous pourrez choisir de fixer cette identifiant à la valeur du port DNS 53 comme ce serveur sera votre DNS.

Red arrow.png Configurez l'adresse statique du serveur

Standard Linux
# ifconfig eth0 add 2001:660:7301:TP_1::53/64
# ip -6 addr add 2001:660:7301:TP_1::53/64 dev eth0


Configuration de la résolution

Vous allez utiliser comme serveur de nommage l'implémentation BIND 9.

Red arrow.png Installez bind9 et la suite d'outils utils sur le PC serveur :

# apt update
Souhaitez vous accepter ces modifications et continuer à mettre à jour depuis ce dépôt ? [o/N] O
Souhaitez vous accepter ces modifications et continuer à mettre à jour depuis ce dépôt ? [o/N] O
# apt-get install bind9
Souhaitez-vous continuer ? [O/n] O
# apt-get install dnsutils
Souhaitez-vous continuer ? [O/n] O

Les noms qui seront utilisé dans le TP seront : serveur.tp pour le serveur, client.tp pour le client. Configurez le serveur pour prendre la configuration de la zone .tp dans le fichier /etc/bind/db.tp.

Red arrow.png Ouvrez le fichier /etc/bind/named.conf.local et éditez la configuration:

zone "tp." {
   type master;
   file "/etc/bind/db.tp";
};

Red arrow.png Ouvrez le fichier /etc/bind/db.tp et éditez la configuration :

tp.  IN SOA  serveur.tp. nobody.localhost. (
                       1          ; serial
                       3600       ; refresh (1 hour)
                       900        ; retry (15 minutes)
                       3600000    ; expire (5 weeks 6 days 16 hours)
                       3600       ; minimum (1 hour)
                       )
              IN   NS      serveur.tp.
serveur.tp.   IN   AAAA   2001:660:7301:TP_1:<ID Interface>
                   AAAA   2001:660:7301:TP_1::53
client.tp.    IN   AAAA   2001:660:7301:TP_1:<ID Interface>

Vous pouvez consulter le site | https://en.wikipedia.org/wiki/SOA_record pour analyser le contenu de ce fichier :

Question.jpg
Quel est le nom de la zone ?




Question.jpg
Qui est le serveur de nom maître primaire pour cette zone ?




Le mot clé NS (Name Serveur) permet de déléguer la gestion d'une zone à un serveur de nom faisant autorité

Question.jpg
Qui est le serveur de nom faisant autorité, auquel on délègue la gestion de cette zone ?




Question.jpg
A quoi correspond la ligne client.tp. IN AAAA 2001:660:7301:TP_1:<ID Interface> ?





Question.jpg
Pourquoi ne publie-t-on pas les adresses lien-local dans le DNS




Red arrow.png Enregistrez le fichier et lancez le serveur DNS

# /etc/init.d/bind9 start

Red arrow.png Vérifiez que la résolution de nom fonctionne sur le serveur et le client

# dig -t AAAA serveur.tp @2001:660:7301:TP_1::53
Question.jpg
Qu'indique la section ANSWER SECTION dans la réponse du dig ?





Red arrow.png Observez les messages de résolution de nom sur l'outil d'analyse de trame

@2001:660:7301:TP_1::53 indique le serveur de nom à consulter, ici le serveur local à la machine.

Question.jpg
Comment modifier la configuration du PC serveur et client pour qu'il utilise automatiquement le serveur DNS que vous venez de configurer pour la résolution de nom





Red arrow.png Mettez à jour les configurations du PC serveur et client pour utiliser le serveur de nommage et testez la résolution : Sur le serveur

# ping6 client.tp

Sur le client

# ping6 serveur.tp

Vous pouvez remarquer que le ping affiche l'adresse IPv6 à chaque ligne, au contraire d'un autre ping comme

# ping6 www.afnic.fr

Cela signifie que la résolution inverse adresse vers nom ne fonctionne pas.

Configuration de la résolution inverse

Comme la résolution de nom, la résolution inverse se base des zones déléguées hiérarchiquement. Mais ici, alors que les noms utilisent des zones textuelles comme .fr, la résolution inverse définit des zones (dites "inverses") à partir des adresses. Par exemple l'adresse 2001:660:3006:1::1:1 (adresse de ns3.nic.fr) est transformée en le nom de domaine inverse suivant :

1.0.0.0.1.0.0.0.0.0.0.0.0.0.0.0.1.0.0.0.6.0.0.3.0.6.6.0.1.0.0.2.ip6.arpa.

Le préfixe ip6.arpa. est commun à toutes les résolutions inverses IPv6. Les sous-domaines suivants sont déterminés à partir de chaque demi-octet (nibble, groupe de 4 bits) de l'adresse IPv6.

Stylo.png
Donnez le domaine inverse de l'adresse IPv6 de votre serveur DNS 2001:660:7301:TP_1::53




Le calcul de ces domaines inverses peut s'avérer propice aux erreurs. Heureusement il existe des outils permettant de les calculer automatiquement à partir des adresses. Vous allez utiliser l'outils ipv6calc pour calculer les résolutions inverses des adresses de votre réseau.

# ipv6calc -O revnibbles.arpa <Adresse IPv6>

Red arrow.png Installez ipv6calc :

# apt-get install ipv6calc

Red arrow.png Calculez grâce à l'outil ipv6calc les résolutions inverses pour les adresses du serveur et du client

Red arrow.png Ajoutez l'entrée dans le fichier de configuration /etc/bind/named.conf.local pour le domaine de résolution inverse de votre TP

zone "tp." {
       type master;
       file "/etc/bind/db.tp";
};

zone "_.P.T.1.0.3.7.0.6.6.0.1.0.0.2.ip6.arpa." {
       type master;
       file "/etc/bind/db.tp.ipv6.rev";
};

Red arrow.png Editez le fichier /etc/bind/db.tp.ipv6.rev contenant la configuration de la résolution inverse Dans ce fichier, nous utiliserons la macro $ORIGIN qui permet de factoriser le suffixe commun des résolutions inverses

/etc/bind/db.tp.ipv6.rev

$ORIGIN _.P.T.1.0.3.7.0.6.6.0.1.0.0.2.ip6.arpa.
$TTL 7200
@       IN SOA  serveur.tp. nobody.localhost. (
                       1          ; serial
                       3600       ; refresh (1 hour)
                       900        ; retry (15 minutes)
                       3600000    ; expire (5 weeks 6 days 16 hours)
                       3600       ; minimum (1 hour)
                       )
       IN      NS      serveur.tp.
 3.5.0.0.0.0.0.0.0.0.0.0.0.0.0.0.1    IN   PTR  serveur.tp.

Red arrow.png Ajoutez les résolutions inverses pour les autres adresses de votre banc.

Red arrow.png Enregistrez le fichier et relancer le serveur de nommage

# /etc/init.d/bind9 restart

Red arrow.png Testez la configuration de la résolution inverse

# dig -x 2001:660:7301:TP_1::53
# ping6 serveur.tp
Question.jpg
Qu'indique la section ANSWER SECTION dans la réponse du dig ?





Remise à zéro des bancs

Red arrow.png Déconnectez tous les câbles réseaux entre les équipements et la baie de brassage.

Red arrow.png Sur le routeur et le commutateur, effacez les configurations avec la commande suivante :

Switch#write erase
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] <return>
[OK]
Erase of nvram: complete
Switch#
3d23h: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Switch#reload

System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]<return>
...
Would you like to terminate autoinstall? [yes]: yes


        --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no
Switch>

Red arrow.png Eteignez les PCs avec la commande :

# shutdown

Broadcast message from root@pc-b27-21 (pts/3) (Mon Aug 11 17:44:28 2008): 

The system is going down for reboot NOW!
Outils personnels